NLS Wants Your Vote! Again...


FSX/P3D...and maybe FS9! In order to determine how high the demand for an FS9 version of the upcoming A380 in development by Next Level Simulations, the team would like you (yes YOU fine sir) to participate in this poll. Please choose the FS9 version if you REALLY want it. If you don't care and use FSX/P3D, then please vote that option. You could possibly vote multiple times but please folks, don't troll the poll! Only vote ONCE!Thank you! Click the provided source link below to cast your vote! And yes... I voted to have an FS9 version.

UPDATE! Unfortunately with the recent poll, users were able to troll the poll and made multiple votes which is exactly what we asked people not to do. Please take a moment and vote again on this new poll found in the source link below.